Ubuntu-Linux

¿Como reparar paquetes rotos y dependencias incumplidas en Debian y Ubuntu?

Si tienes tu sistema a través de un proxy o te interesaría aprender como hacerlo quizás quieras echarle un vistazo a nuestro tutorial sobre Como usar APT a través de un Proxy en Ubuntu 20.04

¿Como reparar paquetes rotos y dependencias incumplidas en Debian y Ubuntu? Esta pregunta es común en cada principiante en una de estas distribuciones de Linux.

Un paquete roto se origina cuando intentamos instalar un paquete y no se instala correctamente o cuando intentamos actualizar el sistema y el proceso se interrumpe debido a problemas de conexión o debido a un paquete dañado o corrupto en su repositorio de origen.

Muchas veces cuando instalamos un paquete este necesita de archivos y paquetes complementarios de los cuales depende para poder instalarse, si se da el caso de que esos archivos y paquetes complementarios no se encuentren ya en el sistema, veremos el error de dependencias incumplidas. Esto se podría solucionar con solo instalar dichos paquetes complementarios, pero aun así, a veces el sistema se queda estancado con ese error. Por ultimo mencionar que en muchos casos no se debe a esto sino simplemente a un paquete roto.

Cuando se nos presente alguno de estos errores no seremos capaces de actualizar, instalar o desinstalar ningún paquete en nuestro sistema.

reparar paquetes rotos

Para reparar paquetes rotos y dependencias incumplidas siga los siguientes pasos:

Usando el gestor de paquetes Synaptic:

  1. Al ejecutar el programa nos dirigimos a la parte inferior izquierda y seleccionamos la opción Filtros
  2. Una vez seleccionada la opción Filtros la otra lista de opciones q aparece encima se actualizará, allí seleccionaremos la opción Rotos
  3. En el espacio de la derecha se mostraran el o los paquetes rotos, haremos clic derecho sobre el que deseamos y seleccionamos la opción Marcar para desinstalarlo completamente
  4. Por último damos a la opción Aplicar en el menú superior

Usando dpkg y el gestor de paquetes apt:

  1. Primero tratemos de configurar aquellos que han sido desempaquetados, pero no configurados
sudo dpkg --configure -a
  1. Si el problema continúa probemos entonces limpiando la caché local de paquetes
sudo apt-get clean
sudo apt-get autoclean
  • Luego reestableceremos la caché eliminada de los repositorios para tratar de detectar y reparar problemas de dependencias en nuestro sistema
sudo apt-get update --fix-missing
  • Ahora usaremos apt para tratar de corregir las dependencias incumplidas y paquetes rotos
sudo apt-get install-f
  1. Si aun siguen presentes los mismos problemas borraremos las lock files de apt y dpkg
sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock
  • Una vez terminado el paso anterior vuelvan a repetir los pasos 1 y 2

Para eliminar pquetes rotos y librarnos de esas dependencias incumplidas siga los siguientes pasos:

  1. Intentemos que el sistema encuentre y elimine el paquete roto
sudo apt-get remove
  1. Si no se tiene éxito busacremos nosotros el paquete roto y acto seguido intentaremos eliminarlo

Buscar paquete:

sudo dpkg -l -| grep ^..r

Eliminar Paquete:

sudo dpkg --remove --force-remove--reinstreq nombre_del_paquete
  • Finalmente limpiaremos la caché local de nuestro repositorio y trataremos de actualizar el sistema

Limpiar cache:

sudo apt-get clean
sudo apt-get autoclean

Actualizar sistema:

sudo apt-get update
sudo apt-get upgrade

Si luego de usar alguna de las opciones anteriores y seguir los pasos indicados puede instalar, actualizar, eliminar aplicaciones o simplemente actualizar el sistema sus problemas de paquetes rotos y dependencias incumplidas habrán terminado.

3 comentarios en “¿Como reparar paquetes rotos y dependencias incumplidas en Debian y Ubuntu?”

  1. Hola, no me funciona, lo he intentado de muchas maneras, pero al final siempre me arroja “Los siguientes paquetes tienen dependencias incumplidas:
    winehq-staging : Depende: wine-staging (= 6.12~groovy-1)
    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
    “, necesito instalar el simulador Codesys pero me es imposible, tampoco me permite usar una maquina virtual.

  2. Buenas,

    estoy tratando de seguir los pasos, pero no hay manera siempre sale lo mismo:
    “Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    Tal vez quiera ejecutar «apt –fix-broken install» para corregirlo.
    Los siguientes paquetes tienen dependencias incumplidas:
    gir1.2-gtk-3.0 : Depende: gir1.2-gdkpixbuf-2.0 (>= 2.40.0) pero 2.36.11-2 está instalado
    gir1.2-pango-1.0 : Depende: libpango-1.0-0 (= 1.44.7-2ubuntu4) pero 1.40.14-1ubuntu0.1 está instalado
    Depende: libpangocairo-1.0-0 (= 1.44.7-2ubuntu4) pero 1.40.14-1ubuntu0.1 está instalado
    Depende: libpangoft2-1.0-0 (= 1.44.7-2ubuntu4) pero 1.40.14-1ubuntu0.1 está instalado
    Depende: libpangoxft-1.0-0 (= 1.44.7-2ubuntu4) pero 1.40.14-1ubuntu0.1 está instalado
    gnupg : Depende: gpgv (>= 2.2.19-3ubuntu2.1)
    hplip : Depende: hplip-data (= 3.20.3+dfsg0-2) pero 3.17.10+repack0-5 está instalado
    Depende: libhpmud0 (= 3.20.3+dfsg0-2) pero 3.17.10+repack0-5 está instalado
    Depende: printer-driver-hpcups (= 3.20.3+dfsg0-2) pero 3.17.10+repack0-5 está instalado
    Depende: libpython3.8 (>= 3.8.2) pero no está instalado
    libgail-3-0 : Depende: libgtk-3-0 (= 3.22.30-1ubuntu4) pero 3.24.20-0ubuntu1 está instalado
    libgtk-3-0 : Depende: libcups2 (>= 2.3~b6) pero 2.2.7-1ubuntu2.8 está instalado
    Depende: libglib2.0-0 (>= 2.57.2) pero 2.56.4-0ubuntu0.18.04.8 está instalado
    Depende: libpango-1.0-0 (>= 1.42.0) pero 1.40.14-1ubuntu0.1 está instalado
    Depende: libpangocairo-1.0-0 (>= 1.41.0) pero 1.40.14-1ubuntu0.1 está instalado
    Depende: libpangoft2-1.0-0 (>= 1.41.0) pero 1.40.14-1ubuntu0.1 está instalado
    Depende: libxcomposite1 (>= 1:0.4.5) pero 1:0.4.4-2 está instalado
    Depende: libgtk-3-common (>= 3.24.20-0ubuntu1) pero 3.22.30-1ubuntu4 está instalado
    libsane-hpaio : Depende: libhpmud0 (>= 3.20.3+dfsg0) pero 3.17.10+repack0-5 está instalado
    python3-apt : Depende: libapt-pkg6.0 (>= 1.9.11~) pero no está instalado
    python3-brlapi : Depende: libbrlapi0.7 pero no está instalado
    python3-gi : Depende: libgirepository-1.0-1 (>= 1.62.0-4~) pero 1.56.1-1 está instalado
    python3-pil : Depende: libimagequant0 (>= 2.11.10) pero no está instalado
    python3-protobuf : Depende: libprotobuf17 pero no está instalado
    python3-uno : Depende: libreoffice-core (= 1:6.4.7-0ubuntu0.20.04.1) pero 1:6.0.7-0ubuntu0.18.04.10 está instalado o
    libreoffice-core-nogui (= 1:6.4.7-0ubuntu0.20.04.1) pero no está instalado
    Depende: libpython3.8 (>= 3.8.2) pero no está instalado
    Depende: libuno-cppu3 (>= 4.4.0~alpha) pero no está instalado
    Depende: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) pero no está instalado
    Depende: libuno-sal3 (>= 5.4.0~alpha) pero no está instalado
    Depende: libuno-salhelpergcc3-3 (>= 3.6.0~beta) pero no está instalado
    Depende: uno-libs-private pero no está instalado
    rhythmbox-plugins : Depende: librhythmbox-core10 (= 3.4.4-1ubuntu2) pero 3.4.2-4ubuntu1 está instalado
    Depende: rhythmbox (= 3.4.4-1ubuntu2) pero 3.4.2-4ubuntu1 está instalado
    Depende: gir1.2-rb-3.0 (= 3.4.4-1ubuntu2) pero 3.4.2-4ubuntu1 está instalado
    E: Dependencias incumplidas. Intente «apt –fix-broken install» sin paquetes (o especifique una solución).

    Podria ayudarme.
    Muchas gracias de antemano

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Top arrow